struts 2.5.3 to 2.5.8

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

struts 2.5.3 to 2.5.8

Emi Lu
Hello,

After updated struts jars from 2.5.3 to 2.5.8, for each action class,
got the following warning message:

java.lang.IncompatibleClassChangeError: class
org.apache.struts2.convention.DefaultClassFinder$InfoBuildingVisitor has
interface org.objectweb.asm.ClassVisitor as super class
     at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_111]
2017-Jan-11 14:28:20.931 [localhost-startStop-1] ERROR
org.apache.struts2.convention.DefaultClassFinder - Unable to read class
[ProcessActionMenu]

Can someone let me know what may cause the above warning message please?

Thanks a lot!

--

Also, it seems that we have to use log4j2.7 but cannot use log4j2.3
anymore? Otherwise, got java.lang.NoSuchMethodError:
org.apache.logging.log4j.Logger.debug(Ljava/lang/String;Ljava/lang/Object;)
exception .


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: struts 2.5.3 to 2.5.8

Emi Lu
Changed asm3.x to 5.2 jars, and the warning message disappear.

> Hello,
>
> After updated struts jars from 2.5.3 to 2.5.8, for each action class,
> got the following warning message:
>
> java.lang.IncompatibleClassChangeError: class
> org.apache.struts2.convention.DefaultClassFinder$InfoBuildingVisitor
> has interface org.objectweb.asm.ClassVisitor as super class
>     at java.lang.ClassLoader.defineClass1(Native Method)
> ~[?:1.8.0_111] 2017-Jan-11 14:28:20.931 [localhost-startStop-1] ERROR
> org.apache.struts2.convention.DefaultClassFinder - Unable to read
> class [ProcessActionMenu]
>
> Can someone let me know what may cause the above warning message please?
>
> Thanks a lot!
>
> --
>
> Also, it seems that we have to use log4j2.7 but cannot use log4j2.3
> anymore? Otherwise, got java.lang.NoSuchMethodError:
> org.apache.logging.log4j.Logger.debug(Ljava/lang/String;Ljava/lang/Object;)
> exception

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: struts 2.5.3 to 2.5.8

Lukasz Lenart
In reply to this post by Emi Lu
2017-01-11 20:35 GMT+01:00 Emi <[hidden email]>:

> Hello,
>
> After updated struts jars from 2.5.3 to 2.5.8, for each action class, got
> the following warning message:
>
> java.lang.IncompatibleClassChangeError: class
> org.apache.struts2.convention.DefaultClassFinder$InfoBuildingVisitor has
> interface org.objectweb.asm.ClassVisitor as super class
>     at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_111]
> 2017-Jan-11 14:28:20.931 [localhost-startStop-1] ERROR
> org.apache.struts2.convention.DefaultClassFinder - Unable to read class
> [ProcessActionMenu]

You have different versions of ASM on the classpath, this was resolved
in 2.5.9 (unreleased yet)

> Also, it seems that we have to use log4j2.7 but cannot use log4j2.3 anymore?
> Otherwise, got java.lang.NoSuchMethodError:
> org.apache.logging.log4j.Logger.debug(Ljava/lang/String;Ljava/lang/Object;)
> exception .

Yes, I mean Struts is using the latest available version but I didn't
spot such problem.


Regards
--
Ɓukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...