Struts 2.5.20 and tiles 2.0.6 with JSF 1.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Struts 2.5.20 and tiles 2.0.6 with JSF 1.2

anjali
Hi,

   Am working on Struts migration from 1.2.9 to 2.5.20. In my application i
have struts only for tiles.So only 10% of my code have struts, that also
standalone. So other 90% of code is in JSF 1.2 with myfaces 1.1.8.
Using,
Tomcat 8.5
maven 3.1.1

So my questions are,

1) Whether struts 2.5.20 + Tiles 2.0.6 + JSF 1.2 will work? or is it
possible?
2) I definitly want to updgrade struts. So which version of tiles will work
with struts 2.5, then whether it will integrate with JSF 1.2.
3)I don want to disturb JSF 1.2 ,  i had modified struts-config.xml to
struts.xml, tiles-definitions.xml to tiles.xml and respective jar changes
also done.
4)TilesInitializer is not happening... Somewhere am missing to integrate
with JSF 1.2?

Please reply if you have any suggestions.
Thanks,
Anjali



--
Sent from: http://struts.1045723.n5.nabble.com/Struts-Dev-f3499899.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Struts 2.5.20 and tiles 2.0.6 with JSF 1.2

Yasser Zamani-2
>1) Whether struts 2.5.20 + Tiles 2.0.6 + JSF 1.2 will work? or is it possible?

Struts 2.5.20 has Tiles 3.0.8 dependency so it seems it won't work with Tiles 2.0.6. I think JSF is completely separate and not related to Struts + Tiles so it will work I think.

>2) I definitly want to updgrade struts. So which version of tiles will work with
>struts 2.5, then whether it will integrate with JSF 1.2.

(same as above)

>3)I don want to disturb JSF 1.2 ,  i had modified struts-config.xml to struts.xml,
>tiles-definitions.xml to tiles.xml and respective jar changes also done.
>4)TilesInitializer is not happening... Somewhere am missing to integrate with JSF
>1.2?

Do you have


    <listener>
        <listener-class>
            org.apache.struts2.tiles.StrutsTilesListener
        </listener-class>
    </listener>

In your web.xml?

Regards.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.5.20 and tiles 2.0.6 with JSF 1.2

John Bush
In reply to this post by anjali
MyFaces 1.1.x is meant for JSF 1.1 - for JSF 1.2 you should be using
MyFaces 1.2.x.

If you don't get this to work, MyFaces has a component called Tomahawk
that is supposed to support Tiles.

Are you aware Tiles was retired end of 2018?

Best of luck,

John

On 5/17/2019 8:52 AM, anjali wrote:

> Hi,
>
>     Am working on Struts migration from 1.2.9 to 2.5.20. In my application i
> have struts only for tiles.So only 10% of my code have struts, that also
> standalone. So other 90% of code is in JSF 1.2 with myfaces 1.1.8.
> Using,
> Tomcat 8.5
> maven 3.1.1
>
> So my questions are,
>
> 1) Whether struts 2.5.20 + Tiles 2.0.6 + JSF 1.2 will work? or is it
> possible?
> 2) I definitly want to updgrade struts. So which version of tiles will work
> with struts 2.5, then whether it will integrate with JSF 1.2.
> 3)I don want to disturb JSF 1.2 ,  i had modified struts-config.xml to
> struts.xml, tiles-definitions.xml to tiles.xml and respective jar changes
> also done.
> 4)TilesInitializer is not happening... Somewhere am missing to integrate
> with JSF 1.2?
>
> Please reply if you have any suggestions.
> Thanks,
> Anjali
>
>
>
> --
> Sent from: http://struts.1045723.n5.nabble.com/Struts-Dev-f3499899.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]