Struts 2.3.14

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Struts 2.3.14

Lukasz Lenart
Hi,

All issues were fixed so I'm going to start a new release process
https://issues.apache.org/jira/projects/WW/versions/12341572

objections?


Regards
--
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Stefaan Dutry-2
Of course you mean version 2.5.14
(since 2.3.14 was created on 28-Mar-2013 :-) )

I just have a single question:
Concerning issue WW-4851 which updates log4j2 -> 2.9.0, should we
update that to version 2.9.1 first?

Regards,
Stefaan Dutry (sdutry)

2017-11-09 18:08 GMT+01:00 Lukasz Lenart <[hidden email]>:

> Hi,
>
> All issues were fixed so I'm going to start a new release process
> https://issues.apache.org/jira/projects/WW/versions/12341572
>
> objections?
>
>
> Regards
> --
> Łukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Lukasz Lenart
2017-11-09 19:37 GMT+01:00 Stefaan Dutry <[hidden email]>:
> Of course you mean version 2.5.14
> (since 2.3.14 was created on 28-Mar-2013 :-) )

Right :)

> I just have a single question:
> Concerning issue WW-4851 which updates log4j2 -> 2.9.0, should we
> update that to version 2.9.1 first?

Good point, we should :) Can you do it?


Regards
--
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Stefaan Dutry-2
>> update that to version 2.9.1 first?

>Good point, we should :) Can you do it?
I'm on it.

Regards,
Stefaan Dutry (sdutry)

2017-11-09 19:53 GMT+01:00 Lukasz Lenart <[hidden email]>:

> 2017-11-09 19:37 GMT+01:00 Stefaan Dutry <[hidden email]>:
>> Of course you mean version 2.5.14
>> (since 2.3.14 was created on 28-Mar-2013 :-) )
>
> Right :)
>
>> I just have a single question:
>> Concerning issue WW-4851 which updates log4j2 -> 2.9.0, should we
>> update that to version 2.9.1 first?
>
> Good point, we should :) Can you do it?
>
>
> Regards
> --
> Łukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Stefaan Dutry-2
> I'm on it.
Done.

Regards,
Stefaan Dutry (sdutry)

2017-11-09 20:00 GMT+01:00 Stefaan Dutry <[hidden email]>:

>>> update that to version 2.9.1 first?
>
>>Good point, we should :) Can you do it?
> I'm on it.
>
> Regards,
> Stefaan Dutry (sdutry)
>
> 2017-11-09 19:53 GMT+01:00 Lukasz Lenart <[hidden email]>:
>> 2017-11-09 19:37 GMT+01:00 Stefaan Dutry <[hidden email]>:
>>> Of course you mean version 2.5.14
>>> (since 2.3.14 was created on 28-Mar-2013 :-) )
>>
>> Right :)
>>
>>> I just have a single question:
>>> Concerning issue WW-4851 which updates log4j2 -> 2.9.0, should we
>>> update that to version 2.9.1 first?
>>
>> Good point, we should :) Can you do it?
>>
>>
>> Regards
>> --
>> Łukasz
>> + 48 606 323 122 http://www.lenart.org.pl/
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Lukasz Lenart
Great! I think we are good to go :)

2017-11-09 20:35 GMT+01:00 Stefaan Dutry <[hidden email]>:

>> I'm on it.
> Done.
>
> Regards,
> Stefaan Dutry (sdutry)
>
> 2017-11-09 20:00 GMT+01:00 Stefaan Dutry <[hidden email]>:
>>>> update that to version 2.9.1 first?
>>
>>>Good point, we should :) Can you do it?
>> I'm on it.
>>
>> Regards,
>> Stefaan Dutry (sdutry)
>>
>> 2017-11-09 19:53 GMT+01:00 Lukasz Lenart <[hidden email]>:
>>> 2017-11-09 19:37 GMT+01:00 Stefaan Dutry <[hidden email]>:
>>>> Of course you mean version 2.5.14
>>>> (since 2.3.14 was created on 28-Mar-2013 :-) )
>>>
>>> Right :)
>>>
>>>> I just have a single question:
>>>> Concerning issue WW-4851 which updates log4j2 -> 2.9.0, should we
>>>> update that to version 2.9.1 first?
>>>
>>> Good point, we should :) Can you do it?
>>>
>>>
>>> Regards
>>> --
>>> Łukasz
>>> + 48 606 323 122 http://www.lenart.org.pl/
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Yasser Zamani
In reply to this post by Lukasz Lenart


On 11/9/2017 8:38 PM, Lukasz Lenart wrote:
> Hi,
>
> All issues were fixed so I'm going to start a new release process
> https://issues.apache.org/jira/projects/WW/versions/12341572
>
> objections?

Is it possible to postpone to tomorrow or Monday? I have some time and
like to ship a small improvement into 2.5.14's train :)

There are reported issues [1] and [2] which are reported because thrown
exception was not informative and clear or even relative!! The problem
is because DefaultValidatorFactory.<init>.parseValidators() encounters
an exception during injections and Struts does not inject rest
injections and user got NPE in other not related places!

I would like to use recently added Initializable mechanism by Łukasz and
remove parseValidators() to init :) This causes all injections done.

[1]
https://issues.apache.org/jira/browse/WW-4876?focusedCommentId=16241525&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16241525
[2]
https://issues.apache.org/jira/browse/WW-4841?focusedCommentId=16125489&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16125489

Sincerely Yours,
Yasser.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Lukasz Lenart
2017-11-11 16:52 GMT+01:00 Yasser Zamani <[hidden email]>:
> Is it possible to postpone to tomorrow or Monday? I have some time and
> like to ship a small improvement into 2.5.14's train :)

Sure, no problem :)


Regards
--
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Yasser Zamani


On 11/12/2017 3:43 PM, Lukasz Lenart wrote:
> Sure, no problem:)

Interesting that I finished exactly on your reply reception :)

Thank you! It's at [1].

[1] https://github.com/apache/struts/pull/185

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Struts 2.3.14

Lukasz Lenart
I think we are good to go

2017-11-12 13:25 GMT+01:00 Yasser Zamani <[hidden email]>:

>
>
> On 11/12/2017 3:43 PM, Lukasz Lenart wrote:
>> Sure, no problem:)
>
> Interesting that I finished exactly on your reply reception :)
>
> Thank you! It's at [1].
>
> [1] https://github.com/apache/struts/pull/185
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]